PrF UG projects configure project

From Protege Wiki

Jump to: navigation, search

Configuring a Project


Protege-Frames User's Guide
Projects
Creating a Project
Opening a Project
Importing a Project
Saving a Project
Converting a Project's Type
Exporting a Project
Renaming a Project
Setting Preferences
Archiving a Project
Reverting to an Archived Project
Including a Project
Activating an Included Project
Removing an Included Project
Merging an Included Project
Configuring a Project
Project Metrics
Using Undo
Glossary, Editing Help

You can change the project configuration using the project Configure dialog box. This dialog box allows you to customize your project window.

Note: You can set additional preferences by choosing File | Preferences. Preferences apply to all Protege projects, while Configuration applies to the current project.

Configuring the Project Tab Widgets

To configure which tabs are displayed:

  1. Select Configure... from the Project menu. The Configure dialog box will open.

    Configure dialog, Tab widgets tab
  2. Make sure that Tab Widgets is selected. It will show the tabs that are available for your project. Marked tabs are visible; others are hidden.

    • By default, a project displays the following tabs: Clses, Slot, Forms, Instances, and Queries.

    • A number of other tabs are available, such as the KAToolTab (Knowledge Acquisition Tool) and the ClsesandInstancesTab.

    • You may see additional tabs for plug-ins you have installed.

    • If you have installed OWL capability, but are not using an OWL project, you will see a list of possible tabs that are not loaded.

  3. To hide a tab, remove the mark from in front of it. For example, if you are giving your project to someone to let them enter instances, you might wish to hide the other tabs. You can also hide the current tab by selecting Window | Close Current View from the Protege project window.

  4. If you wish to display a tab, add a mark in front of it. For example, you might want to display the Classes and Instances tab for a unified view of your classes and instances.

  5. To change the order in which the tabs appear in the Protege project window, highlight the tab you want to move and use the up (projects_object.move_up) and down (projects_object.move_down) icons to move the tab up or down in the list. A tab's position (left to right) in the Protege window is correlated with its position (top to bottom) in the Configure dialog. For example, to have the Classes and Instances tab appear at the far left of the Protege window, move it to the top of the list in the Configure dialog.

  6. Click OK to close the dialog box and see your new configuration.

Configuring Project Options

To change project options:

  1. Select Project | Configure...

  2. Select the Options tab in the Configure dialog box.

    Configure dialog, Options tab
  3. This tab provides the following options:

    • Display Hidden Frames: Allows you to toggle whether or not you can see any frames you have hidden. (You can hide a frame by selecting it, clicking the right mouse button, and choosing Hide from the menu.)

    • Display Confirmation Dialog on 'Remove' Operations: Allows you to add a warning when you perform a remove, such as removing a slot from a class. Recall that when you remove a slot, the slot remains in the project, but is simply removed from the current class. Regardless of the setting in this dialog box, you always receive a warning when you delete a frame from the project.

    • Allow Knowledge-Base Changes: Deselecting this item locks the knowledge base so that it cannot be changed by the viewer.

    • Update Modification Slots: Four system slots (attached to the :INSTANCE-ANNOTATION system class) keep track of the creator, modifier, and timestamps for any frame modification. The system will record this information automatically if you put these slots on the instance (attach them as template slots to the class) and check the box.

    • Enable Journaling: Allows you to keep a record of all the changes that you make to a project. Changes are stored in an ASCII (text) file, with one line for each change you make. The journaling file is created in the same directory as the project, with a .pjrn extension. It can be read using any text editor.

    • Capitalize Slot Widget Labels: This controls an aspect of the Forms interface. To distinguish slot names from class names, a recommended convention is to make internal slot names lowercase. If you use this convention and still want the names on your forms to be capitalized, select this option.

    • Use Tabbed Forms for Multi-Type Instances: Controls the display of the Instance Editor for multi-type instances.

  4. If you wish to select an option, click to mark it.

  5. If you wish to remove an option, click to remove the mark.

  6. Click OK to close the dialog box and see your new configuration.


Personal tools