DroolsTab

From Protege Wiki

Jump to: navigation, search

DroolsTab 5.1

Version 5.1
Plugin DroolsTab
Last update The date "now" was not understood.The date "now" was not understood.
Download DroolsTab 5.1
Compatible Protege Version

Dependency

The following dependencies exist for DroolsTab 5.1:

Changelog

- this version based on latest versions of Protege-Frames, Drools and OpenMap; - many bug fixes; - support for game scenarios.


DroolsTab

by Ruslan Sorokin

Screenshot

Type Tab Widget
Author(s) Ruslan Sorokin
Last Update January 18, 2018
License not available
Homepage DroolsTab website
For Application
Topic(s)
Affiliation

DROOLS BASED SPATIAL SCENARIO SIMULATION PLUG-IN

The DroolsTab uses the open source geo-information system Java library OpenMap and the open source Java RETE rule engine Drools to facilitate visual authoring of complex spatial process simulation scenarios and general rule-based authoring. The Groovy and Clojure languages can be used for authoring auxiliary pieces of code and scripts. The distribution includes several demos of spatial simulation in the sea, air, and ground environments, including one example using Edvin Boehn's KML Framework.

Contents


Versions & Compatibility

This section lists available versions of DroolsTab.

Version Compatible with Dependencies
DroolsTab Protege-Frames 3.5 Drools-5.6
OpenMap-5.1
DroolsTab 5.0 Protege-Frames 3.4

If you click on the button below to add a new version of DroolsTab, you will be asked to define a page title for the new version. Please adhere to the naming convention of DroolsTab X.X.X when you define the new page!

Changelog

Version Changes in this version
DroolsTab - this version based on latest versions of Protege-Frames, Drools and OpenMap;

- many bug fixes;

- support for game scenarios.
DroolsTab 5.0 see page for more details
Personal tools