OWLViz

From Protege Wiki

Jump to: navigation, search

OWLViz

by Matthew Horridge

Screenshot

Type Tab Widget
Author(s) Matthew Horridge
Last Update March 4, 2010
License LGPL
Homepage OWLViz website
For Application
Topic(s)
Affiliation

Enables class hierarchies in an OWL ontology to be viewed and incrementally navigated, allowing comparison of the asserted class hierarchy and the inferred class hierarchy.

Contents


Versions & Compatibility

This section lists available versions of OWLViz.

Version Compatible with Dependencies
OWLViz 4.1.2 Protege-OWL 4.3
Protege-OWL 4.2
Graphviz
OWLViz 4.1.1 Protege-OWL 4.2
Protege-OWL 4.1
Graphviz
OWLViz 3.0 Protege-OWL 3.4.4
Protege Client-Server 3.4.4
Graphviz

If you click on the button below to add a new version of OWLViz, you will be asked to define a page title for the new version. Please adhere to the naming convention of OWLViz X.X.X when you define the new page!

Changelog

Version Changes in this version
OWLViz 4.1.2 Bug fix to allow OWLViz to work with Graphviz 2.30
OWLViz 4.1.1 Recompiled to work with Protege 4.1.
OWLViz 3.0 Fix for edges not showing up when using Graphviz 2.22 or newer.


More Details

Description

OWLViz is designed to be used with the Protege-OWL editor. It enables class hierarchies in an OWL Ontology to be viewed and incrementally navigated, allowing comparison of the asserted class hierarchy and the inferred class hierarchy. OWLViz integrates with the Protege-OWL editor, using the same color scheme so that primitive and defined classes can be distinguished, computed changes to the class hierarchy may be clearly seen, and inconsistent concepts are highlighted in red. OWLViz has the facility to save both the asserted and inferred views of the class hierarchy to various concrete graphics formats including PNG, JPEG, and SVG.

Installation

OWLViz is bundled with the "full" installation of Protege. After you have installed Protege, there are two additional steps you need to perform for this plugin to work properly:

  • Download and install a recent version of Graphviz, which is a free, open source graph visualization software from AT&T Research.
  • Protege will make an educated guess about where to find graphviz depending on your operating system, but if it does not get it right you will need to configure this yourself:
    • Protege3.x and Protege4.0 (pre build 105) on the OWLViz tab, click the Options button to bring up the Options dialog. On the Layout Options panel, specify the path to the location of the DOT executable (dot.exe). The Options dialog will look something like the following, after performing this step:
    • Protege4.x (build 105 onwards) these settings have moved into the OWLViz preferences panel. Again, specify the path to the dot executable in the appropriate place.


OWLViz Options dialog

Documentation

All of the OWLViz documentation is located on the CO-ODE Website. The OWLVizGuide is somewhat outdated, but still very helpful. Also, you may refer to the home pages for the OWLViz plugin for additional information:

Home page for build 17 (Protege3.x): http://www.co-ode.org/downloads/owlviz/.
Home page for build 18 (Protege4.x): http://code.google.com/p/co-ode-owl-plugins/wiki/OWLViz.

Level of Support

OWLViz build 17, which is distributed with Protege-OWL 3.3.1 is no longer under active development. If you need help with this version of OWLViz, please try posting your questions on the protege-owl mailing list, and someone from the Protege user community may be able to help you.

OWLViz build 18, which is bundled with Protege-OWL 4.0 is under active development and all comments, suggestions, and/or feature requests are appreciated! Please post questions and requests on the p4-feedback mailing list.

Troubleshooting

Resolving the "An error related to DOT..." message

Many people report the following error the first time they try to use the OWLViz plugin:


OwlViz-dot-error.jpg


This error message indicates that

a) you need to install Graphviz and/or

b) you need to tell OWLViz where you installed Graphviz.

Instructions for doing both of these things is located above in the Installation section.

Personal tools