PSC 201403 Course Prep

From Protege Wiki

Jump to: navigation, search

Contents


Protege Short Course Preparation

The Protege Short Course is a hands-on course. The purpose of this wiki page is to give detailed instructions for installing the required and optional software components that will be used during the course.

We highly recommend that you install required software on your laptops before the start of the course in order to avoid holding up sessions for software installation issues.

Please note that we do not provide laptops for participants.

If you have questions or problems with software installation, please contact the short course organizers.


Dates: March 26-28, 2014
Location: Room 101, Li Ka Shing Center for Learning and Knowledge, Stanford University, Stanford, California, USA
Course website: http://protege.stanford.edu/shortcourse/201403/index.html


Protege Desktop 4.3 (required)

Protege Desktop is available for download from the Products page on the main Protege website: http://protege.stanford.edu/products.php#desktop-protege.


Protege Desktop 4.3 download page


Installation notes for Mac users:

There are two choices for installing Protege Desktop on the Mac:

  • An OS X application bundle. Hover your mouse over "Other downloads >>" on the Products page to bring up a menu of other download options, and select "OS X App Bundle". The application bundle will automatically expand into your Downloads folder. Open Finder and drag the "Protege-4.3" application from Downloads to the Applications folder.
  • A platform independent installer program. Click the "Download for Mac OSX" button on the Products page and follow the instructions in the resulting download dialog.

Please note that the default Gatekeeper settings for Mountain Lion and above are to restrict application download and installation from the Mac App Store and identified developers. The Protege Desktop software does not carry "identified developer" status, and you may see the following misleading error message when attempting to install:


Mac damaged installer error msg.png


To successfully install Protege, navigate to Apple menu | System Preferences… | Security & Privacy | General tab, and select "Anywhere" from "Allow applications downloaded from".


Pellet Reasoner Plug-in (required)

The "SWRL: Basic concepts" lecture on Tuesday afternoon will require use of the Pellet Reasoner Plug-in. To install the plug-in, launch Protege Desktop and choose the File | Check for plugins... menu item. In the resulting Automatic Update dialog, check the box for the Pellet Reasoner Plug-in on the Downloads tab, and click the Install button.


Automatic Update dialog in Protege 4.3


Click OK on the "Updates will take effect when you next start Protege" dialog, and exit the Protege Desktop application.


Graphviz (optional)

During the ontology visualization session on Thursday afternoon we plan to demo the OWLViz plug-in, which depends on a 3rd-party drawing library called "Graphviz" from AT&T Research. If you think you would like to experiment with this plug-in, please navigate to the Graphviz website to download and install the latest stable version of their software:

http://www.graphviz.org/Download..php

Additional configuration steps will be discussed during the visualization lecture.


Personal tools